ictsupport@fletcher.nl

Incident Report for Fletcher

Resolved

This incident has been resolved.
Posted Nov 24, 2025 - 16:16 CET

Investigating

Momenteel is er een storing bij AFAS/Profit. Voor actuele status zie: https://www.afasstatus.nl/
Posted Nov 24, 2025 - 15:10 CET
This incident affected: AFAS/Profit.