Incident Booking.com reservations

Incident Report for Fletcher

Resolved

Issue has been solved by Booking.
Posted May 22, 2026 - 09:04 CEST

Investigating

At the moment, there is an issue with Booking. As a result, reservations are sometimes not coming through immediately. They are working on a solution.
Posted May 21, 2026 - 16:52 CEST
This incident affected: SHIJI.